re = /(^|\w)#(\w+)/im
str = '#hash //works
#hash_hash //works
#hash_não // get just $hash_n'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end