#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^\s*(?!\s*\d+\s*:)|\d+\s*:)((?:'[^']*'|"[^"]*"|[^;\n])+)"
Local $sString = "0:ID IN (1002,25);1:ID IN (2,3,4) AND COQ>=0 AND COQ<=9;2:ID IN (73150,73150) AND TOTAL>=0 AND TOTAL<=99999" & @CRLF & _
"" & @CRLF & _
"0 :ID IN (1002,25); 1 :ID IN (2,3,4) AND COQ>=0 AND COQ<=9;2:ID IN (73150,73150) AND TOTAL>=0 AND TOTAL<=99999" & @CRLF & _
"" & @CRLF & _
" 0 :NAME = '3:;' OR NAME = "0 : ;" ; 1 :CO>=0;2:TOTAL<=99999" & @CRLF & _
"" & @CRLF & _
"ID IN (1002,25); 1 :ID IN (2,3,4) AND COQ>=0 AND COQ<=9;2:ID IN (73150,73150) AND TOTAL>=0 AND TOTAL<=99999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")