$re = '/(?:^\s*(?!\s*\d+\s*:)|\d+\s*:)((?:\'[^\']*\'|"[^"]*"|[^;\n])+)/m';
$str = '0:ID IN (1002,25);1:ID IN (2,3,4) AND COQ>=0 AND COQ<=9;2:ID IN (73150,73150) AND TOTAL>=0 AND TOTAL<=99999
0 :ID IN (1002,25); 1 :ID IN (2,3,4) AND COQ>=0 AND COQ<=9;2:ID IN (73150,73150) AND TOTAL>=0 AND TOTAL<=99999
0 :NAME = \'3:;\' OR NAME = "0 : ;" ; 1 :CO>=0;2:TOTAL<=99999
ID IN (1002,25); 1 :ID IN (2,3,4) AND COQ>=0 AND COQ<=9;2:ID IN (73150,73150) AND TOTAL>=0 AND TOTAL<=99999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);