using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[[^][\d]*\K\d+(?:\.\d+)?(?=[^][]*])";
string input = @"I have the following expression [+₪7.00], I wish to extract only 7.00 or 7.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}