re = /\[[^][\d]*\K\d+(?:\.\d+)?(?=[^][]*])/m
str = 'I have the following expression [+₪7.00], I wish to extract only 7.00 or 7.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end