$re = '/\b\d+(?:\.\d+)?(?=mcg\b)/m';
$str = 'some text 0.25mcg some more text some text 25mcg some more text
.mcg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);