re = /\b\d+(?:\.\d+)?(?=mcg\b)/m
str = 'some text 0.25mcg some more text some text 25mcg some more text
.mcg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end