#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b([0-9]{1,2}|1[0-9]{2}|2[0-4][0-9]|25[0-5])\b"
Local $sString = "000000000000000" & @CRLF & _
"00" & @CRLF & _
"01" & @CRLF & _
"255" & @CRLF & _
"256" & @CRLF & _
"100" & @CRLF & _
"200" & @CRLF & _
"250"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")