import re
regex = re.compile(r"\b([0-9]{1,2}|1[0-9]{2}|2[0-4][0-9]|25[0-5])\b")
test_str = ("000000000000000\n"
"00\n"
"01\n"
"255\n"
"256\n"
"100\n"
"200\n"
"250")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")