package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)blog(.*)motion$`)
var str = `Je connais un blog indépendant, Blogmotion`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}