$re = '/blog(.*)motion$/i';
$str = 'Je connais un blog indépendant, Blogmotion';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);