package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{4}`)
var str = `25 октября 2016 года`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}