$re = '/\d{4}/';
$str = '25 октября 2016 года';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);