using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![\w-])(row)[^-\w]";
string input = @"row
.row
row-label
howrow
how.row
row > other
rowwer
how>row
how > row
>row
row>other
how-row
ABrow > row";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}