$re = '/(?<![\w-])(row)[^-\w]/m';
$str = 'row
.row
row-label
howrow
how.row
row > other
rowwer
how>row
how > row
>row
row>other
how-row
ABrow > row';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);