const regex = new RegExp('(?=<ul\\s+id=""matchMe""\\s+type=""square""\\s*>) # match start with <ul id="matchMe"...
(?> # atomic group / don\\'t backtrack (faster)
<!-- .*? --> | # match xml / html comment
<[^>]*/\\s*> | # self closing tag
(?<opentag><(?!\\s*/)[^>]*[^/]>) | # push opening xml tag
(?<-opentag><\\s*/[^>]*[^/]>) | # pop closing xml tag
[^<>]* # something between tags
)* # match as many xml tags as possible
(?(opentag)(?!)) # ensure no \\'opentag\\' groups are on stack', 'gs')
const str = `<html>
<body>
<div>
<br />
<ul id="matchMe" type="square">
<li>stuff...</li>
<li>more stuff</li>
<li>
<div>
<p>Lorem ipsum< /p>
<hr class="important" / >
<span>still more</span>
<ul>
<li>Another >ul<, oh my!</li>
<li>...</li>
</ul>
</div>
</li>
</ul>
</div>
</body>
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}