#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s).*(<.*?Hello.*?進撃の巨人.*?Lorem.*?ipsum.*?>).*"
Local $sString = " <html>" & @CRLF & _
" <body>" & @CRLF & _
" <p>Hello <em>進撃の巨人</em>!" & @CRLF & _
" random code" & @CRLF & _
" random code" & @CRLF & _
" <p>Lorem <span>ipsum<span>.<p>" & @CRLF & _
" </body>" & @CRLF & _
" </html>" & @CRLF & _
" "
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)