$re = '/.*(<.*?Hello.*?進撃の巨人.*?Lorem.*?ipsum.*?>).*/s';
$str = ' <html>
<body>
<p>Hello <em>進撃の巨人</em>!
random code
random code
<p>Lorem <span>ipsum<span>.<p>
</body>
</html>
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;