#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm:" & @CRLF & _
" ^" & @CRLF & _
" (?:.*Product\s+Version:\s+)(?<version>\d+\.\d+\.\d+)" & @CRLF & _
" (?:.*status:\s+(?<status>\d+)).*" & @CRLF & _
" $" & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
""
Local $sString = "Property(S): PrimaryVolumeSpaceAvailable = 0" & @CRLF & _
"Property(S): PrimaryVolumeSpaceRequired = 0" & @CRLF & _
"Property(S): PrimaryVolumeSpaceRemaining = 0" & @CRLF & _
"Property(S): ProductToBeRegistered = 1" & @CRLF & _
"MSI (s) (24:7C) [21:56:44:998]: Note: 1: 1707 " & @CRLF & _
"MSI (s) (24:7C) [21:56:44:998]: Product: VetLab Station -- Installation operation completed successfully." & @CRLF & _
"" & @CRLF & _
"MSI (s) (24:7C) [21:56:45:001]: Windows Installer installed the product. Product Name: VetLab Station. Product Version: 4.35.72. Product Language: 1033. Manufacturer: IDEXX Laboratories, Inc.. Installation success or error status: 0." & @CRLF & _
"" & @CRLF & _
"MSI (s) (24:7C) [21:56:45:002]: Value of RebootAction property is " & @CRLF & _
"MSI (s) (24:7C) [21:56:45:002]: Windows Installer requires a system restart. Product Name: VetLab Station. Product Version: 4.35.72. Product Language: 1033. Manufacturer: IDEXX Laboratories, Inc.. Type of System Restart: 1. Reason for Restart: 0."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")