$re = '/(?xm:
^
(?:.*Product\s+Version:\s+)(?<version>\d+\.\d+\.\d+)
(?:.*status:\s+(?<status>\d+)).*
$
)
/';
$str = 'Property(S): PrimaryVolumeSpaceAvailable = 0
Property(S): PrimaryVolumeSpaceRequired = 0
Property(S): PrimaryVolumeSpaceRemaining = 0
Property(S): ProductToBeRegistered = 1
MSI (s) (24:7C) [21:56:44:998]: Note: 1: 1707
MSI (s) (24:7C) [21:56:44:998]: Product: VetLab Station -- Installation operation completed successfully.
MSI (s) (24:7C) [21:56:45:001]: Windows Installer installed the product. Product Name: VetLab Station. Product Version: 4.35.72. Product Language: 1033. Manufacturer: IDEXX Laboratories, Inc.. Installation success or error status: 0.
MSI (s) (24:7C) [21:56:45:002]: Value of RebootAction property is
MSI (s) (24:7C) [21:56:45:002]: Windows Installer requires a system restart. Product Name: VetLab Station. Product Version: 4.35.72. Product Language: 1033. Manufacturer: IDEXX Laboratories, Inc.. Type of System Restart: 1. Reason for Restart: 0.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);