$re = '/^\d{11}$/';
$str = '12345678912
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);