$re = '/(\[(?:[^\[\]]*?|(?R))*\])|(<.*?>)|\G\s([^<>\[\]]+)/';
$str = '<As\'s\\\\as\'dsd> asqwedasd <sa sdasd> [a sadasd] [<asdsad> [as ddsd]] \'asdsad assd\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);