re = /(\[(?:[^\[\]]*?|(?R))*\])|(<.*?>)|\G\s([^<>\[\]]+)/
str = '<As\'s\\\\as\'dsd> asqwedasd <sa sdasd> [a sadasd] [<asdsad> [as ddsd]] \'asdsad assd\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end