$re = '/^\[[0-1][1-9]\-[0-3][0-9]\]/m';
$str = '[01-23]
[02-31]
[02-16]
[ 6-03]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);