// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\[[0-1][1-9]\-[0-3][0-9]\]").unwrap();
let string = "[01-23]
[02-31]
[02-16]
[ 6-03]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}