import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)[\\n](.*?)\\n((?s).*?)(?=\\n\\n\\d|\\Z)";
final String string = "0\n"
+ "00:00:00,000 --> 00:00:00,000\n"
+ "Hello world!\n\n"
+ "1\n"
+ "00:00:00,000 --> 00:00:00,000\n"
+ "Hello world!\n"
+ "This is my new world.\n\n"
+ "2\n"
+ "00:00:00,000 --> 00:00:00,000\n"
+ "Hello guys!\n"
+ "This line contains 123457!\n"
+ "This is third line!\n"
+ "And more lines!\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}