re = /(\d+)[\n](.*?)\n((?s).*?)(?=\n\n\d|\Z)/m
str = '0
00:00:00,000 --> 00:00:00,000
Hello world!
1
00:00:00,000 --> 00:00:00,000
Hello world!
This is my new world.
2
00:00:00,000 --> 00:00:00,000
Hello guys!
This line contains 123457!
This is third line!
And more lines!
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end