import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Help\\s*#\\s*(\\d{3,5})";
final String string = "Help # 7256 \n"
+ "Help # 83930 \n"
+ "ph # 7222\n"
+ "this is a test example\n"
+ "Help # 029299\n"
+ "New # 92929";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}