// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Help\s*#\s*(\d{3,5})").unwrap();
let string = "Help # 7256
Help # 83930
ph # 7222
this is a test example
Help # 029299
New # 92929";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}