const regex = /(0[1-9]|[12][0-9]|3[01])[- \/.](0[1-9]|1[012])[- \/.](19|20)\d\d/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(0[1-9]|[12][0-9]|3[01])[- \\\/.](0[1-9]|1[012])[- \\\/.](19|20)\\d\\d', 'gm')
const str = `12/12/1999
12-12-2000
12/12/2100
12/12/1899`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}