re = /(0[1-9]|[12][0-9]|3[01])[- \/.](0[1-9]|1[012])[- \/.](19|20)\d\d/m
str = '12/12/1999
12-12-2000
12/12/2100
12/12/1899'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end