#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\$.*):\s*([^\s]+)\s*(?:!default);"
Local $sString = "// Colors" & @CRLF & _
"$pf-color-black-100: #fafafa !default;" & @CRLF & _
"$pf-color-black-150: #f5f5f5 !default;" & @CRLF & _
"$pf-color-black-200: #ededed !default;" & @CRLF & _
"$pf-color-black-300: #d2d2d2 !default;" & @CRLF & _
"$pf-color-black-400: #b8bbbe !default;" & @CRLF & _
"$pf-color-black-500: #8a8d90 !default;" & @CRLF & _
"$pf-color-black-600: #737679 !default;" & @CRLF & _
"$pf-color-black-700: #4f5255 !default;" & @CRLF & _
"$pf-color-black-800: #3c3f42 !default;" & @CRLF & _
"$pf-color-black-850: #212427 !default;" & @CRLF & _
"$pf-color-black-900: #151515 !default;" & @CRLF & _
"$pf-color-black-1000: #030303 !default;" & @CRLF & _
"$pf-color-blue-50: #def3ff !default;" & @CRLF & _
"$pf-color-blue-100: #bee1f4 !default;" & @CRLF & _
"$pf-color-blue-200: #73bcf7 !default;" & @CRLF & _
"$pf-color-blue-300: #2b9af3 !default;" & @CRLF & _
"$pf-color-blue-400: #06c !default;" & @CRLF & _
"$pf-color-blue-500: #004080 !default;" & @CRLF & _
"$pf-color-blue-600: #004368 !default;" & @CRLF & _
"$pf-color-blue-700: #002235 !default;" & @CRLF & _
"$pf-color-cyan-100: #a2d9d9 !default;" & @CRLF & _
"$pf-color-cyan-200: #73c5c5 !default;" & @CRLF & _
"$pf-color-cyan-300: #009596 !default;" & @CRLF & _
"$pf-color-cyan-400: #005f60 !default;" & @CRLF & _
"$pf-color-cyan-500: #003737 !default;" & @CRLF & _
"$pf-color-cyan-600: #003d44 !default;" & @CRLF & _
"$pf-color-cyan-700: #001f22 !default;" & @CRLF & _
"$pf-color-gold-100: #f9e0a2 !default;" & @CRLF & _
"$pf-color-gold-200: #f6d173 !default;" & @CRLF & _
"$pf-color-gold-300: #f4c145 !default;" & @CRLF & _
"$pf-color-gold-400: #f0ab00 !default;" & @CRLF & _
"$pf-color-gold-500: #c58c00 !default;" & @CRLF & _
"$pf-color-gold-600: #795600 !default;" & @CRLF & _
"$pf-color-gold-700: #3d2c00 !default;" & @CRLF & _
"$pf-color-green-100: #bde5b8 !default;" & @CRLF & _
"$pf-color-green-200: #95d58e !default;" & @CRLF & _
"$pf-color-green-300: #6ec664 !default;" & @CRLF & _
"$pf-color-green-400: #5ba352 !default;" & @CRLF & _
"$pf-color-green-500: #467f40 !default;" & @CRLF & _
"$pf-color-green-600: #1e4f18 !default;" & @CRLF & _
"$pf-color-green-700: #0f280d !default;" & @CRLF & _
"$pf-color-light-blue-100: #beedf9 !default;" & @CRLF & _
"$pf-color-light-blue-200: #7cdbf3 !default;" & @CRLF & _
"$pf-color-light-blue-300: #35caed !default;" & @CRLF & _
"$pf-color-light-blue-400: #00b9e4 !default;" & @CRLF & _
"$pf-color-light-blue-500: #008bad !default;" & @CRLF & _
"$pf-color-light-blue-600: #005c73 !default;" & @CRLF & _
"$pf-color-light-blue-700: #002d39 !default;" & @CRLF & _
"$pf-color-light-green-100: #e4f5bc !default;" & @CRLF & _
"$pf-color-light-green-200: #c8eb79 !default;" & @CRLF & _
"$pf-color-light-green-300: #ace12e !default;" & @CRLF & _
"$pf-color-light-green-400: #92d400 !default;" & @CRLF & _
"$pf-color-light-green-500: #6ca100 !default;" & @CRLF & _
"$pf-color-light-green-600: #486b00 !default;" & @CRLF & _
"$pf-color-light-green-700: #253600 !default;" & @CRLF & _
"$pf-color-orange-100: #f4b678 !default;" & @CRLF & _
"$pf-color-orange-200: #ef9234 !default;" & @CRLF & _
"$pf-color-orange-300: #ec7a08 !default;" & @CRLF & _
"$pf-color-orange-400: #c46100 !default;" & @CRLF & _
"$pf-color-orange-500: #8f4700 !default;" & @CRLF & _
"$pf-color-orange-600: #773d00 !default;" & @CRLF & _
"$pf-color-orange-700: #3b1f00 !default;" & @CRLF & _
"$pf-color-purple-100: #cbc1ff !default;" & @CRLF & _
"$pf-color-purple-200: #b2a3ff !default;" & @CRLF & _
"$pf-color-purple-300: #a18fff !default;" & @CRLF & _
"$pf-color-purple-400: #8476d1 !default;" & @CRLF & _
"$pf-color-purple-500: #6753ac !default;" & @CRLF & _
"$pf-color-purple-600: #40199a !default;" & @CRLF & _
"$pf-color-purple-700: #1f0066 !default;" & @CRLF & _
"$pf-color-red-100: #c9190b !default;" & @CRLF & _
"$pf-color-red-200: #a30000 !default;" & @CRLF & _
"$pf-color-red-300: #7d1007 !default;" & @CRLF & _
"$pf-color-red-400: #470000 !default;" & @CRLF & _
"$pf-color-red-500: #2c0000 !default;" & @CRLF & _
"$pf-color-white: #fff !default;" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")