import Foundation
let pattern = #"(\$.*):\s*([^\s]+)\s*(?:!default);"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
// Colors
$pf-color-black-100: #fafafa !default;
$pf-color-black-150: #f5f5f5 !default;
$pf-color-black-200: #ededed !default;
$pf-color-black-300: #d2d2d2 !default;
$pf-color-black-400: #b8bbbe !default;
$pf-color-black-500: #8a8d90 !default;
$pf-color-black-600: #737679 !default;
$pf-color-black-700: #4f5255 !default;
$pf-color-black-800: #3c3f42 !default;
$pf-color-black-850: #212427 !default;
$pf-color-black-900: #151515 !default;
$pf-color-black-1000: #030303 !default;
$pf-color-blue-50: #def3ff !default;
$pf-color-blue-100: #bee1f4 !default;
$pf-color-blue-200: #73bcf7 !default;
$pf-color-blue-300: #2b9af3 !default;
$pf-color-blue-400: #06c !default;
$pf-color-blue-500: #004080 !default;
$pf-color-blue-600: #004368 !default;
$pf-color-blue-700: #002235 !default;
$pf-color-cyan-100: #a2d9d9 !default;
$pf-color-cyan-200: #73c5c5 !default;
$pf-color-cyan-300: #009596 !default;
$pf-color-cyan-400: #005f60 !default;
$pf-color-cyan-500: #003737 !default;
$pf-color-cyan-600: #003d44 !default;
$pf-color-cyan-700: #001f22 !default;
$pf-color-gold-100: #f9e0a2 !default;
$pf-color-gold-200: #f6d173 !default;
$pf-color-gold-300: #f4c145 !default;
$pf-color-gold-400: #f0ab00 !default;
$pf-color-gold-500: #c58c00 !default;
$pf-color-gold-600: #795600 !default;
$pf-color-gold-700: #3d2c00 !default;
$pf-color-green-100: #bde5b8 !default;
$pf-color-green-200: #95d58e !default;
$pf-color-green-300: #6ec664 !default;
$pf-color-green-400: #5ba352 !default;
$pf-color-green-500: #467f40 !default;
$pf-color-green-600: #1e4f18 !default;
$pf-color-green-700: #0f280d !default;
$pf-color-light-blue-100: #beedf9 !default;
$pf-color-light-blue-200: #7cdbf3 !default;
$pf-color-light-blue-300: #35caed !default;
$pf-color-light-blue-400: #00b9e4 !default;
$pf-color-light-blue-500: #008bad !default;
$pf-color-light-blue-600: #005c73 !default;
$pf-color-light-blue-700: #002d39 !default;
$pf-color-light-green-100: #e4f5bc !default;
$pf-color-light-green-200: #c8eb79 !default;
$pf-color-light-green-300: #ace12e !default;
$pf-color-light-green-400: #92d400 !default;
$pf-color-light-green-500: #6ca100 !default;
$pf-color-light-green-600: #486b00 !default;
$pf-color-light-green-700: #253600 !default;
$pf-color-orange-100: #f4b678 !default;
$pf-color-orange-200: #ef9234 !default;
$pf-color-orange-300: #ec7a08 !default;
$pf-color-orange-400: #c46100 !default;
$pf-color-orange-500: #8f4700 !default;
$pf-color-orange-600: #773d00 !default;
$pf-color-orange-700: #3b1f00 !default;
$pf-color-purple-100: #cbc1ff !default;
$pf-color-purple-200: #b2a3ff !default;
$pf-color-purple-300: #a18fff !default;
$pf-color-purple-400: #8476d1 !default;
$pf-color-purple-500: #6753ac !default;
$pf-color-purple-600: #40199a !default;
$pf-color-purple-700: #1f0066 !default;
$pf-color-red-100: #c9190b !default;
$pf-color-red-200: #a30000 !default;
$pf-color-red-300: #7d1007 !default;
$pf-color-red-400: #470000 !default;
$pf-color-red-500: #2c0000 !default;
$pf-color-white: #fff !default;
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)