import Foundation
let pattern = #"(?=\*LABEL).\w+\s[“]\w+.[-]?.\w+[”]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
*QUESTION 99924 *ALPHA 1026L3 *DUMMY *VAR “version” *LABEL “SCRIPT VERSION” *PROPERTIES “ReportType=IsShell;ExcludeFromDAU=True”
*QUESTION 270 *CODES 4705L996 *RANDOM *MULTI *MIN 1 *LABEL “BARRIERS_TO_ATTENDENCE - B3” *VAR “BARRIERS_TO_ATTENDENCE” *PROPERTIES “DIMVAR=BARRIERS_TO_ATTENDENCE” *IF [#Q180,1] UIOPTIONS "? ROWPICKER"
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)