using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:DCIM|img)(?:.*)(?:jp.?g|png)";
string input = @"/ext/DCIM/test/123.jpg
/ext/DCIM/test/123.png
/ext/img/test/123.jpg
/ext/img/test/123.jpeg
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}