import re
regex = re.compile(r"(?:DCIM|img)(?:.*)(?:jp.?g|png)")
test_str = ("/ext/DCIM/test/123.jpg\n"
"/ext/DCIM/test/123.png\n"
"/ext/img/test/123.jpg\n"
"/ext/img/test/123.jpeg\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")