const regex = /(?<!\d)\d{8}(?!\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d)\\d{8}(?!\\d)', 'g')
const str = `String_12345678_10
String_123456789_10
String_12345678wordl_10
String_1234567_10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}