$re = '/(?<!\d)\d{8}(?!\d)/';
$str = 'String_12345678_10
String_123456789_10
String_12345678wordl_10
String_1234567_10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);