re = /((?:(?(?=Fig\.|\d+\.\d).+?(?=\s)|[^.!?])+(?=\.))+)/i
str = 'This sentence should be captured because it contains the number 20.
This sentence should be captured because it contains the reference term 20AA.
This sentence should not be captured because it does not contain a number or reference term.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end