package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((([1-9]\d{0,2},(\d{3},)*\d{3}|[1-9]\d*)(.\d{1,4})?)|(0\.\d{1,4}))$`)
var str = `2,000,000
200000.0000
200
200.00000
2,000.00
2,0,00.00
1,234,456.7890
0090
0333333333333.33
3
3.33
.33
0.88`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}