re = /^((([1-9]\d{0,2},(\d{3},)*\d{3}|[1-9]\d*)(.\d{1,4})?)|(0\.\d{1,4}))$/m
str = '2,000,000
200000.0000
200
200.00000
2,000.00
2,0,00.00
1,234,456.7890
0090
0333333333333.33
3
3.33
.33
0.88'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end