$re = '/good \(+(.*?)\)+ phrase/m';
$str = 'good (excellent) phrase
good (too bad) phrase
good ((recursive)) phrase';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);