re = /good \(+(.*?)\)+ phrase/m
str = 'good (excellent) phrase
good (too bad) phrase
good ((recursive)) phrase'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end