#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<date>[\d\-]{10})\s?(?P<time>[\d\:]{8}\.\d{3})\s?<([\d\.]{8})>\s?\[(?P<b>\w+)\]\s?\[(?P<key>.*?)\]\s?<(.*?)>\s?([A-Z]{,3})\s?(\S\w+\.?\d+)\s?\((.*?)\)\s?\"(\w+)\"\s?\((.*?)\)\s?([\d\.]+\s?\w{2,4})$"
Local $sString = "2020-08-14 14:24:16.635 <0.8409.0> [notice] [PHm4QqJJ-t2-RB:0] <[s] API exit> END 217b948f.856614 (inflow out) "RefreshTenantCache" (5252.994 ms) 10.989 ms"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")