re = /^(?P<date>[\d\-]{10})\s?(?P<time>[\d\:]{8}\.\d{3})\s?<([\d\.]{8})>\s?\[(?P<b>\w+)\]\s?\[(?P<key>.*?)\]\s?<(.*?)>\s?([A-Z]{,3})\s?(\S\w+\.?\d+)\s?\((.*?)\)\s?\"(\w+)\"\s?\((.*?)\)\s?([\d\.]+\s?\w{2,4})$/m
str = '2020-08-14 14:24:16.635 <0.8409.0> [notice] [PHm4QqJJ-t2-RB:0] <[s] API exit> END 217b948f.856614 (inflow out) "RefreshTenantCache" (5252.994 ms) 10.989 ms'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end