const regex = /@(\w+).*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@(\\w+).*$', '')
const str = `@foo Hello This is some mention text included.`;
const subst = `@$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);