$re = '/@(\w+).*$/';
$str = '@foo Hello This is some mention text included.';
$subst = "@$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;