const regex = /(?<=\[)([\w:\/]+\s[+\-]\d{4})(?=\])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\[)([\\w:\\\/]+\\s[+\\-]\\d{4})(?=\\])', 'g')
const str = `127.0.0.1 - - [07/Dec/2014:06:43:43 -0800] \\"OPTIONS * HTTP/1.0\\" 200 - \\"-\\" \\"Apache/2.2.14 (Ubuntu) PHP/5.3.2-1ubuntu4.24 with Suhosin-Patch mod_ssl/2.2.14 OpenSSL/0.9.8k mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 (internal dummy connection)\\`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}