re = /(?<=\[)([\w:\/]+\s[+\-]\d{4})(?=\])/
str = '127.0.0.1 - - [07/Dec/2014:06:43:43 -0800] \\"OPTIONS * HTTP/1.0\\" 200 - \\"-\\" \\"Apache/2.2.14 (Ubuntu) PHP/5.3.2-1ubuntu4.24 with Suhosin-Patch mod_ssl/2.2.14 OpenSSL/0.9.8k mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 (internal dummy connection)\\'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end