package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<pronoun>[A-Za-z0-9]+) is (?<adjective>[A-Za-z0-9]+)$`)
var str = `This is good
This this is good`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}